首页/网络/IP 与子网速查/A 类地址(历史分类)1-126 /8
本包目录(177 条)
掩码与 CIDR 速算50 条
私网与特殊地址45 条
子网划分方法与例题40 条IPv6 与下一代网络42 条

A 类地址(历史分类)1-126 /8

有类(classful)时代的 A 类:首字节 1-126、默认掩码 /8,每网 1677 万个地址;CIDR 之后“类”只用于教学与考试,不再决定掩码。

IP 与子网速查网络更新于 2026-10-12
首字节范围1 – 126(最高位为 0)
默认掩码/8(255.0.0.0)
容量每网 16777214 台可用主机
私网代表10.0.0.0/8(RFC 1918)

首字节与网络位

首字节区间类别默认前缀
1 – 126A/8
128 – 191B/16
192 – 223C/24
首字节 127 虽以 0 开头,但被回环地址占用,不算 A 类可分配空间。

易错点

  • 见到 10.1.1.1 就说掩码必是 /8:CIDR 下可任意划 /24、/30
  • 把 127.x 当 A 类可分配空间(回环专用)

数据来源与参考

  • RFC 791(IPv4)
  • RFC 4632(CIDR 取代有类寻址)

相关工具

​‌‌​​‌​​​‌‌​‌‌‌‌​‌‌​​​‌‌​‌‌‌​​‌‌​​‌​‌‌‌​​‌‌‌​​​‌​‌‌​‌​​‌​‌‌‌​​​‌​‌‌​‌​​‌​‌‌​​​‌‌​‌‌‌​‌​​​‌‌​‌‌‌‌​​‌​‌‌‌​​‌‌​​​‌‌​‌‌​‌‌‌‌​‌‌​‌‌​‌